Ultra96 + PYNQ + OpenCV and USB Camera


#1

Hey!
I have pynq 2.3 running in my Ultra96 board, and I’m having difficulties using USB cameras with OpenCV. (I tried using 2 cameras which worked fine with Raspberry Pi and my Laptop running Linux)
I also tried running the examples in the PYNQ Computer Vision library, and the funny thing is that, sometimes a frame is obtained from the camera and the rest of the code works, but when I run it again it fails to capture an image.
Is this a software issue? Both cameras are USB 2.0 devices. Maybe the PYNQ distribution only supports USB 3.0 devices? Because before I changed the OS to PYNQ, I tried running opencv with my cameras on the linux build that was already flashed to the sd card, and everything worked fine.

If I’m unable to get pynq working, can anyone provide me any documentation/tutorials where I can use the other linux build to accelerate image processing?


#2

I have a camera compatible with USB 3.0 and I am having the same issue. I tried MNIST and CIFAR-10 from BNN library, it captures an image when I run the Jupyter snippet the first time and gives an error when I run the second time.


#3

Hi. Check out my project in progress using openCV:


Pretty comprehensive instructions on getting it up and running.


#4

Awesome! Thank you mcallistertad!


#5

As mcallistertad has pointed out, try running the notebook using “Kernel>Restart and Run All”. That worked okay for me. Repeating that action did not produce errors as before.


#6

Can someone point me in the right direction to create a web app that displays the processed image in a fixed frame? Maybe using flask or something similar.


#7

Thanks! I will try that.